tracker issue : CF-3735413

select a category, or use search below
(searches all categories and all time range)
Title:

List member functions should all be prefixed with "list"

| View in Tracker

Status/Resolution/Reason: Closed/Fixed/

Reporter/Name(from Bugbase): Adam Cameron / Adam Cameron (Adam Cameron)

Created: 04/02/2014

Components: Language

Versions: 11.0

Failure Type: Usability Issue

Found In Build/Fixed In Build: PublicBeta /

Priority/Frequency: Normal / Most users will encounter

Locale/System: English / Platforms All

Vote Count: 5

G'day:
See community feedback: http://cfmlblog.adamcameron.me/2014/04/survey-results-lists-in-cfml-and-naming.html

The current approach to the list member functions is poorly designed, due to it not being clar what's a string member function and what's a list one. eg: oneString.append(anotherString) looks like it does what it suggests: appends a string to another. It does NOT look like it does a listAppend() (which is what it does).

Pls revise, and prefix all list member functions with "list".

Cheers

-- 
Adam

----------------------------- Additional Watson Details -----------------------------

Watson Bug ID:	3735413

External Customer Info:
External Company:  
External Customer Name: Adam Cameron.
External Customer Email:  
External Test Config: My Hardware and Environment details:

Attachments:

Comments:

Consistency is important. Please don't cause confusion of "list" member functions with string member functions: keep the list-prefix on all "list" member functions. Or just drop the idea of "list" member functions altogether since CFML doesn't really have a "list" data type, it's just a set of list-prefixed functions that do special stuff to strings (and leads to horribly inefficient code in many CFML programs!).
Vote by External U.
12886 | April 02, 2014 08:20:51 PM GMT
Please don't make things more confusing for new developers, or provide more ammunition for ColdFusion antagonists. Keep list functions distinct from regular string functions by maintaining a "list*" prefix on list member functions.
Vote by External U.
12887 | April 02, 2014 10:08:12 PM GMT
Consistency, Consistency,Consistency
Vote by External U.
12888 | April 03, 2014 02:23:23 AM GMT
Thank you Adobe for listening to community feedback!
Comment by External U.
12883 | April 03, 2014 04:11:43 PM GMT
+1 on Sean. Good work Adobe Team. -- Adam
Comment by External U.
12884 | April 03, 2014 05:39:25 PM GMT
Or.... drop the list prefix altogether. Either way, be consistent.
Vote by External U.
12889 | April 03, 2014 08:58:23 PM GMT
Just noting that these list member functions were not prefixed w/ 'list': changeDelims(), each(), filter(), map(), reduce(), sort(), valueCount() and valueCountNoCase(). Please see #CF-3752316 for further discussion. Additionally, myList.filter() hasn't been implemented yet. (#CF-3755346) Thanks!, -Aaron
Comment by External U.
12885 | May 06, 2014 12:10:09 AM GMT
+1 - For consistency, please prefix * list member functions w/ "list".
Vote by External U.
12890 | May 06, 2014 12:11:56 AM GMT